redsn0w #fail

Da ich „das eine oder andere“ Problem mit meinem iPhone 3G hatte, wollte ich es mal wieder „neuinstallieren“.

Zuerst wollte ich PwnageTool verwenden, um mir eine „Custom Firmware“ zu bauen. Die Firmware liess sich auch wunderprächtig mit ein paar ausgewählten Cydia Paketen (wie z.B. biteSMS oder OpenSSH – Must Haves!) bauen – aber iTunes weigerte sich, diese Firmware auf das iPhone zu installieren → #fail #1.

Also gut, dann eben kein PwnageTool und stattdessen redsn0w, dachte ich mir. redsn0w braucht die original Firmware Dateien für das iPhone. Auf Felix‘ Seite habe ich Links zu allen Firmwares gefunden. Für das iPhone 3G (ohne S!) braucht’s die iPhone1,2_… Dateien, für 3.0 also iPhone1,2_3.0_7A341_Restore.ipsw und für Firmware 3.0.1 wäre es iPhone1,2_3.0.1_7A400_Restore.ipsw. Die 2,1’er Dateien tun nicht so wirklich dolle auf ’nem iPhone 3G, wie ich festgestellt habe…🙂

Nachdem die Downloads fertig waren, wollte ich mal eben kurz redsn0w verwenden, um das iPhone zu unlocken. Nuja. Die Idee war vermutlich schon richtig, aber…

Angefangen habe ich mit der 0.8’er Version für Mac in OSX. Hat die 3.0’er Firmware auch akzeptiert, aber leider blieb das iPhone (oder redsn0w?) dann bei „Waiting for Reboot“ hängen. War also schon mal nix → #fail #2. Das ist im übrigen aber auch kein neuer Fehler – schon „damals“, als die 3.0’er Firmware raus kam, konnte ich das iPhone nicht mit redsn0w 4 Mac „beglücken“ (da hatte ich’s nicht mit meinem MacBook Pro versucht, sondern mit einem iMac). Insofern hat mich dieser #fail also nicht sonderlich überrascht.

Gut, dann also nur dafür Bootcamp aktivieren und Windows XP Home installieren. ’ne knappe Stunde später (Windows installiert sich ja soooooo schnell…. *schnarch*), konnte ich redsn0w für Windows ausprobieren. Ausprobieren. Das bedeutet, es hat „natürlich“ nicht geklappt, denn leider hat XP im Bootcamp sich geweigert, das iPhone im DFU Modus zu erkennen. Ergo konnte redsn0w auch nicht die „angepasste“ Firmware installieren → #fail #3.

Okay, gibt ja noch redsn0w für Linux. Auch hier war eine Installation nicht von Erfolg gekrönt → #fail #4.

Zum Glück hatte ich irgendwo aber noch einen Rechner mit einem „richtigen“ Windows XP zur Verfügung. Und da hat es dann endlich funktioniert.

Summa summarum muss ich doch mal wieder festhalten, das es mich mächtig anzickt, das Apple das iPhone so total „zugenagelt“ hat. Tut das wirklich not? IMO: Nee, tut’s nicht😦 #Apple → #fail!

Update:

Wie man auf’m Dev-Team Blog (und sicher auch woanders…) lesen kann, ist die Lösung für #fail #2 ganz einfach: USB Kabel rausziehen und wieder reinstecken🙂 Klappt tatsächlich! Trotzdem merkwürdig, das dies bei meinem iPhone nötig ist (hat übrigens nichts mit dem MacBook zu tun, da ich auf ’nem iMac mit redsn0w nicht jailbreaken konnte). Naja, sei’s drum…🙂

Schreibe einen Kommentar

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s